#1 24.07.2014 00:15:41

chomwitt
Player
Posts: 38

Install older versions in ubuntu .

I have 14.04 .

List of freeciv versions in ubuntu: http://packages.ubuntu.com/search?keywords=freeciv

1) We add the new sources  (be carefull! freeciv in ubuntu is in 'universe'.
$ cd /etc/apt/sources.list.d
$ sudo nano saucy.list
deb http://gr.archive.ubuntu.com/ubuntu/ saucy main restricted
deb-src http://gr.archive.ubuntu.com/ubuntu/ saucy main restricted

deb http://gr.archive.ubuntu.com/ubuntu/ saucy universe
deb-src http://gr.archive.ubuntu.com/ubuntu/ saucy universe
deb http://gr.archive.ubuntu.com/ubuntu/ saucy-updates universe
deb-src http://gr.archive.ubuntu.com/ubuntu/ saucy-updates universe

2) Run:
$ sudo apt-get update

3) Run:  ( -V for seeing exactly installed version..to be sure!)
$ sudo apt-get -V  -t saucy install freeciv-client-gtk

Offline

#2 12.01.2015 16:07:03

chomwitt
Player
Posts: 38

Re: Install older versions in ubuntu .

After an update to my Ubuntu 14.04 LST system i noticed that freeciv was upgraded and i lost my 2.3  version i had installed with the steps from the previous post.

I checked http://packages.ubuntu.com/search?keywords=freeciv and now there is now package for saucy version.

So i've done the same steps but this time for precise.

Purge all related freeciv packages before installing again with:
sudo apt-get -V  -t precise  install freeciv-client-gtk

Offline

Board footer

Powered by FluxBB