#1 02.05.2015 02:00:36

chomwitt
Player
Posts: 38

Install older versions of freeciv in Debian 8 (Jessie)

In a fresh installation of Debian 8 (Jessie) we see that 2.4.3-3 is available. But installing and trying to connect to a 2.3.x longturn server we get:
This client missed a capability that the server wants
image.png

So we need a way to install 2.3.x .
From the PTS page of freeciv we see that oldstable has 2.3.2

From the Debian Releases  page we see that oldstable was wheezy

# su                                                  //change to root
# cd /etc/apt/sources.list.d/
# nano wheezy.list                                          // we could use an online source generator like debgen.simplylinux.ch  to help us but  i see is not update now, but it will help to have sth to work on . In my case , and choosing Greece for the repository mirror i get the following (i just had to change stable to wheezy)
       deb http://ftp.gr.debian.org/debian/ wheezy  main
       deb-src http://ftp.gr.debian.org/debian/ wheezy main
# apt-get update                              // update package info , we can do that also from aptitude

If we try to search for freeciv in  aptitude we still dont see the oldder version we want (maybe that could be changed by a setting ? ) but from the shell :
# apt-get -V  -twheezy  install freeciv-client-gtk 
and we see that the list of packages about to be installed is the rigth one. We confirm and after the installation the freeciv 2.3.2 is installed.

As a precaution i  personally try to inactive wheezy.list  to avoid possible messing with my stable debian system.
# cd /etc/apt/sources.list.d/
# mv wheezy.list wheezy.list-NO
and now after an # apt-get update  we get the message:
N: Ignoring file 'wheezy.list-NO' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

Offline

Board footer

Powered by FluxBB